一、修复软件升级源报错

1.注释掉不可用源

nano /etc/apt/sources.list.d/pve-enterprise.list

注释掉

#deb https://enterprise.proxmox.com/debian/pve stretch pve-enterprise

2.手动修复升级

echo "deb http://download.proxmox.com/debian/pve stretch pve-no-subscription" > /etc/apt/sources.list.d/pve-install-repo.list
wget http://download.proxmox.com/debian/proxmox-ve-release-5.x.gpg -O /etc/apt/trusted.gpg.d/proxmox-ve-release-5.x.gpg
apt update && apt dist-upgrade

二、修复订阅报错

nano /usr/share/javascript/proxmox-widget-toolkit/proxmoxlib.js
if (data.status !== 'Active') {

替换为

if (false) {

三、修复启动时候的driver ‘pcspkr’ is already registered,aborting报错

使用命令:

dmesg |grep -i 'lookup'

查看信息表。

[ 0.000000] ACPI Error: [\_SB_.PCI0.XHC_.RHUB.HS11] Namespace lookup failure, AE_NOT_FOUND (20170831/dswload-210)
[ 0.000000] ACPI Exception: AE_NOT_FOUND, During name lookup/catalog (20170831/psobject-252)
echo "blacklist snd-pcsp" >> /etc/modprobe.d/blacklist.conf